Sunday, February 12, 2012

2960 & 3560 交换机限速


2960交换机限速
2010-04-19 22:43:37
标签:交换机 限速

配置 
mls qos 

class-map match-all classmap 
match access-group 47 


policy-map policymap 
class classmap 
    police 1000000 8000 exceed-action drop 


interface FastEthernet0/47 
switchport mode access 
service-policy input policymap 
spanning-tree portfast 


access-list 47 permit any
3560交换机限速: 
在3560 EMI上做速率限制是采用QOS的速率管制功能(policying),依次需要做如下配置。
1、在所有端口上关闭流量控制
3560(config)#interface range gigabitEthernet 0/1 - 12
3560(config-if-range)#flowcontrol receive off
3560(config-if-range)#flowcontrol send off
2、启用QOS
3560(config)#mls qos
3560#show mls qos
QoS is enabled
3、依次配置ACL、Class-map、Policy-map并应用在Gi0/8接口下:
access-list 110 permit ip host 10.10.11.25 any
class-map match-all All-IPTraffic
match access-group 110
policy-map QOS
class All-IPTraffic
police 2048000 102400 exceed-action drop
interface GigabitEthernet0/8
switchport access vlan 3
switchport mode access
service-policy input QOS
flowcontrol send off
no cdp enable

No comments:

Entertainment