Wednesday, January 4, 2012

Cisco MPLS 流量工程

流量工程配置案例:

1、  拓扑图:

点击查看原图

 

2、  环境介绍:

Cisco Router 3640 version 12.4

3、  配置说明:

R1、R2和R3互连;R1和R3之间建立一条TE隧道;R1、R2和R3,各起Loopback0。

4、  具体配置:

R1:

mpls traffic-eng tunnels                          /*启用mpls-te功能*/
!
interface Loopback0
ip address 200.1.1.1 255.255.255.0
!
interface Tunnel1                                  /*配置隧道tunnel1*/
ip unnumbered Loopback0                          /*配置隧道ip,同ip address配置*/
tunnel destination 200.1.1.3                     /*配置该隧道的目的地址*/
tunnel mode mpls traffic-eng                     /*配置隧道的模式为mpls-te*/
tunnel mpls traffic-eng autoroute announce       /*配置该隧道的自动路由功能*/
tunnel mpls traffic-eng priority 6 6             /*配置该隧道的优先级*/
tunnel mpls traffic-eng bandwidth  3000          /*配置该隧道的带宽*/
tunnel mpls traffic-eng path-option 16 explicit name t1     /*配置隧道的显示路径*/
tunnel mpls traffic-eng record-route             /*配置隧道记录标签信息*/
!
interface Ethernet0/0
ip address 12.1.1.1 255.255.255.0
mpls traffic-eng tunnels                         /*接口模式下使能mpls-te功能*/
ip rsvp bandwidth 15000                          /*配置接口的总te带宽*/
!
router ospf 89
mpls traffic-eng router-id Loopback0             /*使能ospf-te的mpls-te router-id*/
mpls traffic-eng area 0                          /*在ospf-te area 0中使能mpls-te*/
network 12.1.1.0 0.0.0.255 area 0
network 200.1.1.1 0.0.0.0 area 0
!
ip explicit-path name t1 enable                  /*配置隧道使用的显示路径*/
next-address 12.1.1.2
next-address 23.1.1.3
!

R2:

mpls traffic-eng tunnels                         /*启用mpls-te功能*/
!
interface Loopback0
ip address 200.1.1.2 255.255.255.0
!
interface Ethernet0/1
ip address 12.1.1.2 255.255.255.0
mpls traffic-eng tunnels                         /*接口模式下使能mpls-te功能*/
ip rsvp bandwidth 10000                          /*配置接口的总te带宽*/
!
interface Ethernet0/0
ip address 23.1.1.2 255.255.255.0
mpls traffic-eng tunnels                         /*接口模式下使能mpls-te功能*/
ip rsvp bandwidth 15000                          /*配置接口的总te带宽*/
!
router ospf 89
mpls traffic-eng router-id Loopback0             /*使能ospf-te的mpls-te router-id*/
mpls traffic-eng area 0                          /*在ospf-te area 0中使能mpls-te*/
network 12.1.1.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
network 200.1.1.2 0.0.0.0 area 0
!

R3:

mpls traffic-eng tunnels                          /*启用mpls-te功能*/
!
interface Loopback0
ip address 200.1.1.3 255.255.255.0
!
interface Tunnel1                                 /*配置隧道tunnel1*/
ip unnumbered Loopback0                           /*配置隧道ip,同ip address配置*/
tunnel destination 200.1.1.1                      /*配置该隧道的目的地址*/
tunnel mode mpls traffic-eng                      /*配置隧道的模式为mpls-te*/
tunnel mpls traffic-eng autoroute announce        /*配置该隧道的自动路由功能*/
tunnel mpls traffic-eng priority 6 6              /*配置该隧道的优先级*/
tunnel mpls traffic-eng bandwidth  3000           /*配置该隧道的带宽*/
tunnel mpls traffic-eng path-option 16 explicit name t3     /*配置隧道的显示路径*/
tunnel mpls traffic-eng record-route              /*配置隧道记录标签信息*/
!
interface Ethernet0/1
ip address 23.1.1.3 255.255.255.0
mpls traffic-eng tunnels                          /*接口模式下使能mpls-te功能*/
ip rsvp bandwidth 15000                           /*配置接口的总te带宽*/
!
router ospf 89
mpls traffic-eng router-id Loopback0              /*使能ospf-te的mpls-te router-id*/
mpls traffic-eng area 0                           /*在ospf-te area 0中使能mpls-te*/
network 23.1.1.0 0.0.0.255 area 0
network 200.1.1.3 0.0.0.0 area 0
!
ip explicit-path name t3 enable                   /*配置隧道使用的显示路径*/
next-address 23.1.1.2
next-address 12.1.1.1
!

5、  Mpls-te-tunnel诊断:

当完成了R1上TE的相关配置后,即不配置R3斜体字部分,使用如下命令:

R1# show mpls traffic-eng tunnels brief

点击查看原图

结果如图2:


当完成了R1上TE的相关配置后,即不配置R3斜体字部分,使用如下命令:

R3# show mpls traffic-eng tunnels brief

点击查看原图


结果如图3:

No comments: